HS4.010 not starting on latest WIN10
2018-11-16 13:48
Hi, HS3 has no problem, HS4 runs ok on my old WIN-XP laptop but no longer on my WIN-10 system
since a windows 10 update somewhere September October 2018, HS4 does not start up on my desktop computer but generates a JET error
message: JET RUNTIME HAS DETECTED UNRECOVERABLE ERROR: system exception at 0x00b358cd please contact the vendor of the application. Extra information about error is saved in the "jer_err_10672.txt" file. In this file it says as a start:

Exception 0xC0000005 (EXCEPTION_ACCESS_VIOLATION) at 0x00b358cd (C:\HamSphere\HamSphere_4.010\HamSphere_4.010.exe+0xb258cd)
Failed to read memory at 0x01abe000

PID 2088, TID 480

Registers:

EAX = 0x400000 EBX = 0x16BE000
ECX = 0x6 EDX = 0x16BE
ESI = 0x2D7 EDI = 0xD41398
EBP = 0x1EDFF00 ESP = 0x1EDFEE0
EIP = 0x00b358cd (C:\HamSphere\HamSphere_4.010\HamSphere_4.010.exe+0xb258cd)

than the complete stack
than version info:

Java version: 1.7.0_80
Excelsior JET 10.50 Professional edition
JET Profile: Java SE version: 1.7.0_80; JET update level: 5; CPU architecture: x86
Runtime: Desktop
CPU features: cmov mmx sse sse2 sse3 ssse3 sse4.1 sse4.2 avx avx2 fma f16c lzcnt popcnt bmi1 bmi2 cx8 cx16 movbe
Application was deployed

I checked and cleaned my computer, uninstalled HS4 and Java, downloaded the latest versions, no success.
Now I am running out of ideas

73 Hans, 3da0aq
Re: HS4.010 not starting on latest WIN10
2018-11-16 14:12
Hi Hans,

Try running the HamSphere 4.0 program as "Administrator"
Re: HS4.010 not starting on latest WIN10
2018-11-17 14:18
ran as administrator, tested compatibility with WinXP and Win7 both without success so sent the error file to Microsoft.
I regret my status loss as DX user since there are only four radio hams in Swaziland active on short wave and only one (me) active on Hamsphere. I like to use Hamsphere 4 when conditions on real shortwave are unusable. The prediction plug-in is excellent. 73, de Hans, 3da0aq
Re: HS4.010 not starting on latest WIN10
2018-11-25 19:52
windows - settings - privacy - microphone privacy - allow apps to use microphone
Re: HS4.010 not starting on latest WIN10
2018-11-27 10:53
everything on microphone setting is on now apps were on, still no HS4 startup, HS3 ok
Re: HS4.010 not starting on latest WIN10
2018-11-27 22:49
Hello Hans,

if it is a 64bit system, install HamSphere ONLY in the 32bit folder (x86) and run it as an Administrator. Otherwise it won't will work.
This should help.

73 and good DX from Jörg :-)
JO31ok
Bochum / Germany
Re: HS4.010 not starting on latest WIN10
2018-11-28 06:12
JET RUNTIME HAS DETECTED UNRECOVERABLE ERROR: system exception at 0x00b358cd
Please, contact the vendor of the application.

Exception 0xC0000005 (EXCEPTION_ACCESS_VIOLATION) at 0x00b358cd (C:\Program Files (x86)\HamSphere\HamSphere_4.010.exe+0xb258cd)
Failed to read memory at 0x01abe000

PID 4228, TID 8148

As you can see, I now run it in the right directory, tried compatibility versions, cleaning the registry, but still similar error
Re: HS4.010 not starting on latest WIN10
2018-11-28 11:55
Indeed that is strange. Maybe your Computer has a physical conflict at this memory-adress? (0x00b358cd and 0x01abe000, could be a defect RAM-Chip)

Such errors on special adresses you can see if a software try to adress a specified adress-range from the RAM. If you got this error, either this range is defect (physical) or another program / application is using this area at the same moment.
But "normally" a system will adress dynamically, not with a fix adress.

73 and good DX from Jörg :-)
JO31ok
Bochum / Germany
Re: HS4.010 not starting on latest WIN10
2018-11-29 07:59
You are right there, since it is a fixed address it might be the routine that looks for the microphone presence, common to many utilities.
C programmers are sometimes not consistent freeing up memory used, it must be a lately installed utillity or driver. This address might be a microphone hook.
73 de Hans
Re: HS4.010 not starting on latest WIN10
2020-05-14 01:08
Hi Hans,

did you ever fix the problem ?

I am having the same and cannot figure it out.

W100 x64 on very latest updates
Tried Java7 and Java8.
Tried Microphone access to Apps

Nothing works .....

Any help would be appreciated.

73 / Francis /15HS623
Re: HS4.010 not starting on latest WIN10
2020-05-17 08:23
15HS623 Wrote:
-------------------------------------------------------
> Hi Hans,
>
> did you ever fix the problem ?
>
> I am having the same and cannot figure it out.
>
> W100 x64 on very latest updates
> Tried Java7 and Java8.
> Tried Microphone access to Apps
>
> Nothing works .....
>
> Any help would be appreciated.
>
> 73 / Francis /15HS623
Re: HS4.010 not starting on latest WIN10
2020-05-17 08:24
problem dissappeared at later Win 10 update. no problem since then
case closed
73
Hans
Sorry, only registered users may post in this forum.

Click here to login