Technical Problems and Videos Views Posts Last Post
Forum Search needs fixing. by 2HS8935 537 3 2017-10-31 03:43
Last Post by 242HS392
Not picking uo on HS 4.0 by KI4OYV 401 3 2017-10-17 23:56
Last Post by 3HS8123
Log in problems by N8RXX 964 5 2017-10-17 22:34
Last Post by 3HS8123
Hamsphere doesn't load. by 79HS1619 1,556 5 2017-09-26 15:44
Last Post by 57HS2311
HamSphere 4.0.10 Crashing. Need some guidance by 47HS598 936 5 2017-07-30 10:23
Last Post by 2HS2357
Questions regarding the program. by 2HS9125 339 2 2017-04-22 10:52
Last Post by 13HS1807
I NEED HELP IN AUDIO by 117HS102 4,182 18 2017-04-10 12:51
Last Post by 13HS1807
HS4 Cluster defect? by 13HS1807 298 2 2017-03-13 18:03
Last Post by 13HS1807
the program is cutting itself by 161HS3390 314 1 2017-03-03 21:23
Last Post by 161HS3390
chat function closed? by G4HAK 1,806 5 2017-01-18 20:00
Last Post by 30HS6206
Doesnt work on win 7 64bit by 2M0CDD 3,512 16 2017-01-12 05:11
Last Post by 2HS4685
How TO change Radio size ? by 2HS6206 2,671 5 2017-01-09 01:31
Last Post by 2HS6462
trouble starting HamSphere   (Pages: 1 2) by 26HS340 7,338 42 2017-01-06 14:14
Last Post by VO2JAS
Hamsphere 4 Stopped Working. SOLVED by G3VGU 833 8 2017-01-02 11:38
Last Post by G7VAC
Fldigi for Hamsphere by 26HS2447 3,722 8 2016-11-09 18:03
Last Post by 47HS542
Change in Callsign by KF7UIG 3,469 26 2016-10-21 12:45
Last Post by 5B4AIT
Hamsphere Blog Site not available? by N4MBN 674 2 2016-09-25 17:31
Last Post by 9HS4652
Installing 4.0 giving me problems by K6RVD 556 1 2016-09-24 18:07
Last Post by K6RVD
"ALERT! Network problems. Disconnect!" - iPhone 6S Plus by 2HS7800 764 5 2016-08-28 07:03
Last Post by 43HS2680
Empty Window - Firewall - Solved by KE0JVX 590 2 2016-07-31 18:56
Last Post by KE0JVX
Not booting up by M6RLR 648 1 2016-07-20 19:23
Last Post by M6RLR
banned account recuperation by 76HS129 711 1 2016-07-01 01:21
Last Post by 76HS129
New call sign by KI7DIS 599 2 2016-05-09 11:40
Last Post by 13HS1807
Ha sphere doesn't cover 7.272 on 40m and I have a net there Why no coverage by W4BNN 549 2 2016-04-27 22:14
Last Post by 13HS1807
Notice Hamsphere en Français by F0FZS 15,619 22 2016-03-12 17:49
Last Post by 14HS3985
no sound and TX Audio Driver (No Codec) by 14HS1908 3,211 9 2016-02-03 21:53
Last Post by KF6ZB
no activety by S57BO 814 1 2016-01-14 22:03
Last Post by S57BO
3.x and 4.x on Ubuntu Linux 14.10 - Audio "Skipping" by 2HS2832 1,068 3 2015-12-16 23:42
Last Post by KA0YTV
windows 10 by 79HS2677 1,143 1 2015-11-26 01:51
Last Post by 79HS2677
Wrong PIN for iPhone App?!? by KM4ONB 770 1 2015-11-24 14:55
Last Post by KM4ONB